Like Prometheus, but for logs.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
loki/nix/packages/loki.nix

38 lines
880 B

{ pkgs, version, imageTag, lib }:
pkgs.buildGo123Module {
inherit version;
pname = "loki";
src = ./../..;
vendorHash = null;
ldflags =
let
prefix = "github.com/grafana/loki/v3/pkg/util/build";
in
[
"-s"
"-w"
"-X ${prefix}.Branch=nix"
"-X ${prefix}.Version=${imageTag}"
"-X ${prefix}.Revision=${version}"
"-X ${prefix}.BuildUser=nix@nixpkgs"
"-X ${prefix}.BuildDate=unknown"
];
subPackages = [ "cmd/loki" ];
nativeBuildInputs = with pkgs; [ makeWrapper ];
doCheck = false;
meta = with lib; {
description = "Like Prometheus, but for logs";
mainProgram = "loki";
license = with licenses; [ agpl3Only ];
homepage = "https://grafana.com/oss/loki/";
changelog = "https://github.com/grafana/loki/commit/${version}";
maintainers = with maintainers; [ trevorwhitney ];
};
}